Last change
on this file was
2,
checked in by Erik Enge, 21 years ago
|
Initial revision
|
-
Property svn:eol-style set to
native
-
Property svn:executable set to
*
-
Property svn:keywords set to
Author Date Id Revision
|
File size:
1.6 KB
|
Line | |
---|
1 | #!/usr/bin/make -f |
---|
2 | |
---|
3 | pkg := cl-irc |
---|
4 | debpkg := cl-irc |
---|
5 | |
---|
6 | |
---|
7 | clc-source := usr/share/common-lisp/source |
---|
8 | clc-systems := usr/share/common-lisp/systems |
---|
9 | clc-irc := $(clc-source)/$(pkg) |
---|
10 | |
---|
11 | doc-dir := usr/share/doc/$(debpkg) |
---|
12 | |
---|
13 | |
---|
14 | configure: configure-stamp |
---|
15 | configure-stamp: |
---|
16 | dh_testdir |
---|
17 | # Add here commands to configure the package. |
---|
18 | touch configure-stamp |
---|
19 | |
---|
20 | |
---|
21 | build: build-stamp |
---|
22 | |
---|
23 | build-stamp: configure-stamp |
---|
24 | dh_testdir |
---|
25 | # Add here commands to compile the package. |
---|
26 | touch build-stamp |
---|
27 | |
---|
28 | clean: |
---|
29 | dh_testdir |
---|
30 | dh_testroot |
---|
31 | rm -f build-stamp configure-stamp |
---|
32 | # Add here commands to clean up after the build process. |
---|
33 | rm -f debian/cl-irc.postinst.* debian/cl-irc.prerm.* |
---|
34 | dh_clean |
---|
35 | |
---|
36 | install: build |
---|
37 | dh_testdir |
---|
38 | dh_testroot |
---|
39 | dh_clean -k |
---|
40 | # Add here commands to install the package into debian/irc. |
---|
41 | dh_installdirs $(clc-systems) $(clc-irc) $(doc-dir) |
---|
42 | dh_install cl-irc.asd $(shell echo *.lisp) $(clc-irc) |
---|
43 | dh_link $(clc-irc)/cl-irc.asd $(clc-systems)/cl-irc.asd |
---|
44 | |
---|
45 | # Build architecture-independent files here. |
---|
46 | binary-indep: build install |
---|
47 | |
---|
48 | # Build architecture-dependent files here. |
---|
49 | binary-arch: build install |
---|
50 | dh_testdir |
---|
51 | dh_testroot |
---|
52 | # dh_installdebconf |
---|
53 | dh_installdocs doc CREDITS README TODO |
---|
54 | dh_installexamples example/* |
---|
55 | # dh_installmenu |
---|
56 | # dh_installlogrotate |
---|
57 | # dh_installemacsen |
---|
58 | # dh_installpam |
---|
59 | # dh_installmime |
---|
60 | # dh_installinit |
---|
61 | # dh_installcron |
---|
62 | # dh_installman |
---|
63 | # dh_installinfo |
---|
64 | # dh_undocumented |
---|
65 | dh_installchangelogs |
---|
66 | dh_strip |
---|
67 | dh_compress |
---|
68 | dh_fixperms |
---|
69 | # dh_makeshlibs |
---|
70 | dh_installdeb |
---|
71 | # dh_perl |
---|
72 | dh_shlibdeps |
---|
73 | dh_gencontrol |
---|
74 | dh_md5sums |
---|
75 | dh_builddeb |
---|
76 | |
---|
77 | binary: binary-indep binary-arch |
---|
78 | .PHONY: build clean binary-indep binary-arch binary install configure |
---|
79 | |
---|
Note: See
TracBrowser
for help on using the repository browser.