wiki:BuildClisp
close Warning: Can't synchronize with repository "(default)" (/project/clfswm/public_html/git/clfswm.git does not appear to be a Git repository.). Look in the Trac log for more information.

Version 1 (modified by pbrochard, 10 years ago) (diff)

--

Here is a way to build Clisp with the mit/clx

tar xzvf clisp-VERSION.tar.gz
cd clisp-VERSION
./configure build
cd build
./makemake --with-dynamic-ffi  --srcdir=../src --with-module="clx/mit-clx"   > Makefile
cp -p ../src/cfgunix.lisp config.lisp
chmod +w config.lisp
echo '(setq *clhs-root-default* "http://www.lisp.org/HyperSpec/")' >> config.lisp
make
make check
su
make install

Here is my whole script - I use two differents users (install and local) and my ln_local script

#!/bin/sh -x

VERSION=$(lynx -dump http://clisp.cons.org/ | grep version | sed -e "s/^.*: //g" -e "s/ (.*$//g")
#VERSION=2.44.1
EXT=tar.gz
EXTRACT=xzvf

echo Compiling: $VERSION.$EXT
 
wget ftp://ftp.gnu.org/pub/gnu/clisp/release/$VERSION/clisp-$VERSION.$EXT
  
tar $EXTRACT clisp-$VERSION.$EXT
  
cd clisp-$VERSION
 
./configure build
  
cd build
./makemake --with-dynamic-ffi  --srcdir=../src --prefix="/usr/install/clisp-$VERSION/" --with-module="clx/mit-clx"   > Makefile
cp -p ../src/cfgunix.lisp config.lisp
chmod +w config.lisp
echo '(setq *clhs-root-default* "http://www.lisp.org/HyperSpec/")' >> config.lisp

make
make check

echo -n "Install "
su install -c "rm -rf /usr/install/clisp* && make install"

echo -n "Local "
su local -c "ln_local clean do && cd /usr/install/clisp-$VERSION && ln_local create do"

cd ../..
rm -rf clisp-$VERSION clisp-$VERSION.$EXT