close Warning: Can't synchronize with repository "(default)" (/project/oct/public_html/git/oct.git does not appear to be a Git repository.). Look in the Trac log for more information.

Opened 5 years ago

Closed 4 years ago

#5 closed defect (fixed)

(sin +pi+) should not be zero

Reported by: rtoy Owned by: somebody
Priority: major Milestone:
Component: Core Version:
Keywords: Cc:

Description

Since +pi+ is not the mathematical pi, (sin +pi+) cannot be zero.

This is caused by doing a sloppy pi reduction for small args.

Change History (1)

comment:1 Changed 4 years ago by toy.raymond@…

  • Resolution set to fixed
  • Status changed from new to closed

commit 6127a79e0d6300bc7ac7754190fbd559d00e7401
Author: Raymond Toy <toy.raymond@…>
Date: Sun Nov 24 10:41:27 2013 -0800

Fix ticket:5


o Implement better pi reduction and also always do pi reduction.
o Add test for sin(pi) and cos(2120), to test pi reduction.
o Accuracy for erfc is only 198 bits.

Note: See TracTickets for help on using tickets.