close Warning: Can't synchronize with repository "(default)" (/project/cmucl/public_html/git/cmucl.git does not appear to be a Git repository.). Look in the Trac log for more information.

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#48 closed defect (fixed)

RCS keywords in git

Reported by: rtoy Owned by: somebody
Priority: minor Milestone:
Component: Core Version: 2011-09
Keywords: Cc:

Description

With the move to git, all of the RCS keywords in the sources are now obsolete. Something needs to be done with them.

We can use git filters to add RCS keywords. This really slows down cloning.

Carl suggested modifying the compiler so that file-comments are handled specially by calling out to git to get the appropriate information. Some tests indicate this slows down compilation by about 20%, caused by running git to look up the information.

Still need to deal with some other RCS keywords that aren't in the file-comment.

Change History (2)

comment:1 Changed 6 years ago by toy.raymond@…

  • Resolution set to fixed
  • Status changed from new to closed

commit 822fd79aef8e3d85a05c3d9b7cea5e080b802184 Author: Raymond Toy <toy.raymond@…> Date: Sat Sep 24 22:48:26 2011 -0700

Fix ticket:48. Use Carl's idea to use git to insert the appropriate comment into the compiled file. If git is not found or if some other error occurs, the file comment is whatever string was given.

Need to update the file-comments of every file to remove erroneous dates and revisions.

comment:2 Changed 6 years ago by toy.raymond@…

commit 99a5797f72ae3a43d8e5909653770f044f993c17 Author: Raymond Toy <toy.raymond@…> Date: Sat Sep 24 23:10:18 2011 -0700

Fix ticket:49. In every file-comment, replace the existing $Header$ entries with just the file path, removing the revision number, date, author and state. The actual information is now computed during compilation and stored in the fasl itself. (See ticket:48.)

Note: See TracTickets for help on using tickets.