close Warning: Can't synchronize with repository "(default)" (/project/cmucl/public_html/git/cmucl.git does not appear to be a Git repository.). Look in the Trac log for more information.

Opened 6 years ago

Closed 6 years ago

#75 closed defect (fixed)

cl-unicode regression in 2013-03

Reported by: Anton Vodonosov Owned by: somebody
Priority: major Milestone:
Component: Core Version: 2013-03
Keywords: Cc:

Description

I can load library cl-unicode in cmucl-20d, but not in 2013-03 snapshot.

In the example below I use Quicklisp to load the library. To workaround ASDF upgrade issue between the recent Quicklisp and CMUCL, ASDF is loaded explicitly before Quicklisp.

./lisps/cmucl-20d/bin/lisp -noinit -nositeinit -load quicklisp/asdf.lisp -load ./quicklisp/setup.lisp
(ql:quickload :cl-unicode)
=> OK
./lisps/cmucl-2013-03/bin/lisp -noinit -nositeinit -load quicklisp/asdf.lisp -load ./quicklisp/setup.lisp
(ql:quickload :cl-unicode)


Error in function LISP::ASSERT-ERROR:
   Unknown property name "OtherGraphemeExtend".
   [Condition of type SIMPLE-ERROR]

Restarts:
  0: [CONTINUE       ] Retry assertion with new value for DESIGNATOR.
  1:                   Return NIL from load of #P"/home/testgrid/.cache/common-l                               isp/cmu-snapshot-2013-03__20d_unicode_-linux-x86/home/testgrid/quicklisp/dists/q                               uicklisp/software/cl-unicode-0.1.4/alias.sse2f".
  2: [TRY-RECOMPILING] Recompile alias and try loading it again
  3: [RETRY          ] .Retry
                       loading FASL for #<CL-SOURCE-FILE "cl-unicode" "alias">.
  4: [ACCEPT         ] Continue, treating
                       loading FASL for #<CL-SOURCE-FILE "cl-unicode" "alias">
                       as having been successful.
  5: [ABORT          ] Give up on "cl-unicode"
  6:                   Return to Top-Level.

Debug  (type H for help)

(LISP::ASSERT-ERROR TEST-FUNCTION
                    (DESIGNATOR)
                    "Unknown property name ~S."
                    "OtherGraphemeExtend")
Source: Error finding source:
Error in function DEBUG::GET-FILE-TOP-LEVEL-FORM:  Source file no longer exists:
  target:code/macros.lisp.
0] backtrace 10

0: (LISP::ASSERT-ERROR TEST-FUNCTION
                       (DESIGNATOR)
                       "Unknown property name ~S."
                       "OtherGraphemeExtend")
1: ((LABELS COLLECT-TEST-FUNCTIONS BUILD-DERIVED-TEST-FUNCTION)
    ("Me" "Mn" "OtherGraphemeExtend"))
2: (BUILD-DERIVED-TEST-FUNCTION ("Me" "Mn" "OtherGraphemeExtend"))
3: (BUILD-DERIVED-TEST-FUNCTIONS)
4: (BUILD-ALL-PROPERTY-TESTS)
5: (C::DO-CALL #<Code Object "Top-Level Form" {5904515F}> 16 17 7 ...)
6: (LISP::FOP-FUNCALL-FOR-EFFECT)
7: (LISP::LOAD-GROUP
    #<Stream for file "/home/testgrid/.cache/common-lisp/cmu-snapshot-2013-03__20d_unicode_-linux-x86/home/testgrid/quicklisp/dists/quicklisp/software/cl-unicode-0.1.4/alias.sse2f">)
8: (LISP::FASLOAD
    #<Stream for file "/home/testgrid/.cache/common-lisp/cmu-snapshot-2013-03__20d_unicode_-linux-x86/home/testgrid/quicklisp/dists/quicklisp/software/cl-unicode-0.1.4/alias.sse2f">)
9: (LISP::INTERNAL-LOAD
    #P"/home/testgrid/.cache/common-lisp/cmu-snapshot-2013-03__20d_unicode_-linux-x86/home/testgrid/quicklisp/dists/quicklisp/software/cl-unicode-0.1.4/alias.sse2f"
    #P"/home/testgrid/.cache/common-lisp/cmu-snapshot-2013-03__20d_unicode_-linux-x86/home/testgrid/quicklisp/dists/quicklisp/software/cl-unicode-0.1.4/alias.sse2f"
    :ERROR :BINARY
    ...)

Change History (2)

comment:1 Changed 6 years ago by Raymond Toy

Thanks for the report. I believe this error might be due to bug #76, which I think I've just fixed. With that fix applied, I can load cl-unicode just fine. If you wish to do some testing with this, I can supply a test binary for you.

comment:2 Changed 6 years ago by Raymond Toy

Resolution: fixed
Status: newclosed

Fixed by ticket:76

Note: See TracTickets for help on using tickets.