close Warning: Can't synchronize with repository "(default)" (/project/cmucl/public_html/git/cmucl.git does not appear to be a Git repository.). Look in the Trac log for more information.

Opened 6 years ago

Closed 6 years ago

#99 closed defect (fixed)

Error when CMUCL tries to print style warning

Reported by: Anton Vodonosov Owned by: somebody
Priority: major Milestone:
Component: Core Version: 2014-05
Keywords: Cc:

Description (last modified by Raymond Toy)

Possible way to reproduce:

(ql:quickload :cl-base64 :verbose t)

Example log, with a backtrace: http://cl-test-grid.appspot.com/blob?key=dig7txag0w

As you can see from the backtrace, CMUCL tries to print style-warning, and the warning printing produces an error, so the library compilation process fails at all.

The file being compiled: http://git.b9.com/?p=cl-base64.git;a=blob_plain;f=encode.lisp;hb=f375d1fc3a6616e95ae88bb33493bb99f920ba13

As far as I understand, the warning happens because the ROUND-NEXT-MULTIPLE function code declares result of CL:MOD to be a FIXNUM, while it is a REAL.

I saw this error during warning printing at 2015-01 snapshot and 2014-05 snapshot.

Change History (1)

comment:1 Changed 6 years ago by Raymond Toy

Description: modified (diff)
Resolution: fixed
Status: newclosed

CMUCL is actually trying to print out most-negative-fixnum. This bug was fixed in commit c34d88b5 and will be available in the next snapshot.

Closing this bug.

Note: See TracTickets for help on using tickets.